SMS MFA + Email Integration Service Disruption

Incident Report for Casca

Resolved

This incident has been resolved. Please contact Casca directly if you observe any continued disruption.
Posted Jun 12, 2025 - 18:06 EDT

Monitoring

We're observing a dramatic decrease in error rates, but some user currently remain affected. We'll continue to provide updates as we work towards full recovery
Posted Jun 12, 2025 - 16:38 EDT

Identified

We have identified that this issue is a result of an ongoing outage impacting Google Cloud Platform, Cloudflare, and associated services. We will continue to provide updates as we work to resolve.
Posted Jun 12, 2025 - 15:20 EDT

Update

We are continuing to investigate this issue.
Posted Jun 12, 2025 - 14:52 EDT

Investigating

Casca engineering is investigating an issue preventing users with SMS-based MFA from logging in.
Posted Jun 12, 2025 - 14:51 EDT
This incident affected: Applicant Portal.