We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 13:31 EDT
Monitoring
We’re aware of outages across Amazon Web Services (AWS) impacting a variety of providers across the internet. https://health.aws.amazon.com/
Casca’s core platform remains operational. Most critical functionalities are working as expected. Document generation is currently not functional.
Some users may experience disruption or delays with integrations that rely on external third-party APIs, including Identity Verification & Credit Retrieval.
We're monitoring the situation as our providers approach recovery and will provide updates as we have them.
Posted Oct 20, 2025 - 03:15 EDT
This incident affected: Document Generation and Plaid API - Production.